Scroll ↕

The PFiddlesoft Frameworks require Mac OS X 10.7 (Lion) or newer. Both frameworks have been verified through macOS Sierra 10.12. They support new Accessibility features Apple has added over the years. They support the Intel 64-bit architecture using reference counted memory management or ARC. They are designed to be installed as shared frameworks or embedded in an application package. They support client applications that are written using the Objective-C and Swift programming languages.

Older versions of both frameworks are available for older versions of macOS. PFAssistive Framework 3.2.0 and PFEventTaps Framework 1.3.5 support Mac OS X 10.6 (Snow Leopard), and PFAssistive Framework 3.1.2 and PFEventTaps Framework 1.3.2 support Mac OS X 10.5 (Leopard). Versions of the Frameworks for Mac OS X 10.4 (Tiger) or earlier are no longer offered. Visit Downloads to download these older versions of the frameworks.